Account Administration: Trouble loading the People view

Incident Report for 1Password

Resolved

We have resolved an issue where account administrators are unable to load the "People" view when logging in to their account on 1Password.com, 1Password.ca, and 1Password.eu.
Posted Jun 13, 2025 - 16:33 EDT

Identified

We have identified an issue where account administrators are unable to load the "People" view when logging in to their account on 1Password.com, 1Password.ca, and 1Password.eu. Our engineers are actively working to deploy a fix for this issue.
Posted Jun 13, 2025 - 15:05 EDT
This incident affected: Enterprise (Admin console).